Published: Wed 09 December 2015
Revisions: Sun 27 March 2016
Mon 21 March 2016

wordpress certificate error preventing upgrade

I had the following problem after upgrading my wordpress installation to 4.4: SSL certificate problem, verify that the CA cert is OK. Details: error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed.

The problem is that wordpress ships its own, old certificate bundle. You can fix this by downloading http://curl.haxx.se/ca/cacert.pem and overwrite your /wp-includes/certificates/ca-bundle.crt with it.

This will be needed after every wordpress upgrade that does not fix the issue itself which is probably an outdated server missing the certificate or a php version being compiled with an old version of openSSL.

Previous: Teaching theoretical computer science in January , Next: Gnome Foundation membership renewed

links

social

Theme based on notmyidea